I would say this is the better approach, since it will work with a list of any length.
(Note, however, that you should NOT name your list variable
list, because then if you need to convert something else into a list using the
list(...) function, you won't be able to, because you've redefined the identifier
list to refer to your list instead of to the
list function! Use
myList or some other name instead.)